Page 1 of 1

BladeMaster launches, unable to move in the Arena

Posted: Sat Sep 10, 2022 8:56 pm
by TheCheese
Hello, thanks for the fantastic project!

I'm trying to setup the BladeMaster module (LOGBM) - I can launch the bbs, go into the game, hit 'P' for Play, then 'A' to enter the Arena, then press Enter to select the Ruffians. After this, the P and A keys appear to work, but if I try to move with the numpad, the session appears to freeze and I'm unable to get any further response. (I've tried both numlock on and off). If I disconnect the session at this point, MBBSEmu crashes with:

Code: Select all

2022-09-10 17:50:04.3871 Warn MBBSEmu.Session.SocketSession.CloseSocket Session (Channel: 0) Client disconnected
2022-09-10 17:50:04.4047 Info MBBSEmu.HostProcess.MbbsHost.RemoveSession Removing Channel: 0
Unhandled exception. System.ArgumentOutOfRangeException: Specified argument was out of the range of valid values.
   at MBBSEmu.Memory.ProtectedModeMemoryCore.VirtualToPhysical(UInt16 segment, UInt16 offset)
   at MBBSEmu.Memory.AbstractMemoryCore.GetWord(UInt16 segment, UInt16 offset)
   at MBBSEmu.CPU.CpuCore.GetOperandValueUInt16(OpKind opKind, EnumOperandType operandType)
   at MBBSEmu.CPU.CpuCore.Op_Cmp()
   at MBBSEmu.CPU.CpuCore.Tick()
   at MBBSEmu.HostProcess.ExecutionUnits.ExecutionUnit.Execute(FarPtr entryPoint, UInt16 channelNumber, Boolean simulateCallFar, Boolean bypassState, Queue`1 initialStackValues, UInt16 initialStackPointer)
   at MBBSEmu.Module.MbbsModule.Execute(FarPtr entryPoint, UInt16 channelNumber, Boolean simulateCallFar, Boolean bypassSetState, Queue`1 initialStackValues, UInt16 initialStackPointer)
   at MBBSEmu.HostProcess.MbbsHost.CallModuleRoutine(String routine, Action`1 preRunCallback, UInt16 channel)
   at MBBSEmu.HostProcess.MbbsHost.RemoveSession(UInt16 channel)
   at MBBSEmu.HostProcess.MbbsHost.RemoveSessions(Predicate`1 match)
   at MBBSEmu.HostProcess.MbbsHost.WorkerThread()
   at System.Threading.Thread.StartCallback()
Aborted (core dumped)
MBBS OS: Ubuntu 22.04.1
MBBS version: Stable Alpha - v1.0-alpha-042822
Client OS: Ubuntu 22.04.1
Client program: telnet (I've also tried syncterm)

Any idea what I'm missing? Thanks!